The Leviy platform is currently unavailable | Het Leviy platform is momenteel niet bereikbaar
Incident Report for Leviy
Resolved
This incident has been resolved.
Posted May 26, 2020 - 17:01 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2020 - 16:57 CEST
Investigating
Our engineers are investigating the cause of the problem.

Onze engineers onderzoeken de oorzaak.
Posted May 26, 2020 - 16:42 CEST
This incident affected: Dashboard, Mobile App, Accounts, Files, Analytics, API, and Email Notifications.